Saturday, 28 March 2020

RHEL/CentOS 8 Error: problem with installed package podman-docker

If you guys are facing an error while installing Docker CE on Centos/RHEL 8 as follow:




Here is the workaround For CentOS/RHEL:


Uninstall podman before updating it sudo yum -y remove podman and install it back w/o manpages:
# install all podman dependencies except podman-manpages
sudo yum -y install oci-systemd-hook libvarlink
Then again install docker-ce

# install docker-ce
sudo yum -y install docker-ce
It should work this time!

If still facing an issue, try to use --nobest flag with command


$ sudo dnf -y  install docker-ce --nobest

Workaround for For Ubunutu:

sudo apt install -o Dpkg::Options::="--force-overwrite" podman


Thanks!!! Enjoy Programming :)


Reference Links:
=============================

https://github.com/containers/libpod/issues/4791#issuecomment-575124857


No comments:

Post a Comment

Thanks for your valuable comments.

Elasticsearch: Copy Index Structure