Sunday, 29 March 2020

RHEL/CentOS 8 docker-ce installation Error: package docker-ce-3:19.03.8-3.el7.x86_64 requires >= 1.2.2-3

If you are facing the error while installing docker-ce as follow:

To fix it, you can either install a specific stable version like:

$ sudo dnf install docker-ce-3:18.09.1-3.el7


you can force the installation of docker-ce with the --nobest option

$ sudo dnf install --nobest docker-ce


Install the latest available package manually

$ sudo dnf install

After the package is installed, we can simply install the latest docker-ce

$ sudo dnf install docker-ce

This option is less convenient since the package is not installed 
as a dependency of docker-ce, therefore it will not be removed automatically when 
the latter is uninstalled from the system.

I hope it will fix your issue!!

Thanks!!!!!!! Enjoy Programming :)

Reference Links

No comments:

Post a Comment

Thanks for your valuable comments.