Thursday, 25 March 2021

Odoo Error: The 'odoo.addons.web' package was not installed in a way that PackageLoader understands.

 If you are facing this error in odoo12



It means the proper package version of Jinja2 is not installed.


Try installing this one:

pip3 install Jinja2==2.10.1

It should solve your problem.


Thanks!!! Enjoy Programming! :)

Monday, 1 February 2021

Elasticsearch Error: Format version is not supported



When I downgraded Elasticsearch 7.10 to 7.6, I was not able to restart the elasticsearch service and was facing these errors:



and 



After diagnosing the issue and going through a number of web URLs, I come to know that the following line in the elasticsearch.yml file will fix my issue.


cluster.initial_master_nodes: ["x.x.x.x"]


OR 


cluster.initial_master_nodes: master-node-a    


I hope it will help someone and save their time too.


Thanks!!! Enjoy Programming!! :)

Wednesday, 9 December 2020

ElasticSearch 7.x not working after upgrade


In case you have upgraded elastic search by mistake and want to rollback to the previous working version, here are the steps.

In my case, I upgraded the ElasticSearch to 7.9.2-1 and wanted to rollback to 7.6.2-1

1. yum downgrade elasticsearch-7.6.2-1

2. Restart elasticsearch

sudo service elasticsearch start

I hope it will work but in case you are facing any of the following issues, please run respective comments.


Errors:

Problem. Unable to create temporary keystore at [/etc/elasticsearch/elasticsearch.keystore.tmp]

Solution: sudo -u elasticsearch -s /usr/share/elasticsearch/bin/elasticsearch-keystore create


Problem: Likely root cause: java.nio.file.AccessDeniedException: /etc/elasticsearch

Solution: chmod g+w /etc/elasticsearch


Thanks!! Enjoy Programming!


Reference Links

====================================

https://discuss.elastic.co/t/unable-to-create-temporary-keystore-at-etc-elasticsearch-elasticsearch-keystore-tmp/136411


Monday, 28 September 2020

SSL(Self-Signed) Certificates are working fine on Firefox and Safari, but not on Chrome

Yesterday, I implemented self-signed SSL certificates to one of my websites, and to my surprise https link was working as expected on Safari and Firefox, but not on the Chrome browser. I was getting the following error:




With this, I connected with my IT team and come to know that, the certificates are not generated properly. All the browsers support different SSL expiry dates and we had to raise requests again to generate SSL Certificates for a minimum duration which was of 398 days (Apple) so that it can support all the browsers and new certificates worked without any issue.


Edit: 28-09-2020

Looks like all the Browser developers such as Google, Apple, Microsoft, and Mozilla have agreed to keep the SSL Certificate Lifespan common - 398 days. Please read more about it here:

https://securityboulevard.com/2020/07/mozilla-cuts-ssl-certificate-lifespans-keyfactor


Thanks!! Enjoy Programming!! :)


Saturday, 4 April 2020

Odoo: Qweb Templates Cache Issue




Hi Everyone, Today I was working on a hotel booking template in Odoo and changes made in the Qweb template(.xml) were not reflecting on updating module with odoo service restart. Tried few times without any success :(. Finally, I decided to delete the old template from Odoo backend and then update module again and it worked like a charm!! :)

Steps to delete template from backend:

Settings --> User Interface --> Views --> Search by template name

Delete the used template.

Although it's a small post, but I'm sure it will meet the purpose and help someone in the future.


Thanks!!!

Enjoy Programming!! :)


Reference Links:
===================================

https://www.odoo.com/forum/help-1/question/odoo-cache-and-updating-qweb-templates-84492

Sunday, 29 March 2020

RHEL/CentOS 8 docker-ce installation Error: package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io >= 1.2.2-3

If you are facing the error while installing docker-ce as follow:




To fix it, you can either install a specific stable version like:

$ sudo dnf install docker-ce-3:18.09.1-3.el7


OR
 

you can force the installation of docker-ce with the --nobest option


$ sudo dnf install --nobest docker-ce

OR


Install the latest available containerd.io package manually


$ sudo dnf install 
https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm

After the package is installed, we can simply install the latest docker-ce


$ sudo dnf install docker-ce

This option is less convenient since the containerd.io package is not installed 
as a dependency of docker-ce, therefore it will not be removed automatically when 
the latter is uninstalled from the system.


I hope it will fix your issue!!


Thanks!!!!!!! Enjoy Programming :)

Reference Links
===================================

https://linuxconfig.org/how-to-install-docker-in-rhel-8


Saturday, 28 March 2020

RHEL/CentOS 8 Error: problem with installed package podman-docker

If you guys are facing an error while installing Docker CE on Centos/RHEL 8 as follow:




Here is the workaround For CentOS/RHEL:


Uninstall podman before updating it sudo yum -y remove podman and install it back w/o manpages:
# install all podman dependencies except podman-manpages
sudo yum -y install oci-systemd-hook libvarlink
Then again install docker-ce

# install docker-ce
sudo yum -y install docker-ce
It should work this time!

If still facing an issue, try to use --nobest flag with command


$ sudo dnf -y  install docker-ce --nobest

Workaround for For Ubunutu:

sudo apt install -o Dpkg::Options::="--force-overwrite" podman


Thanks!!! Enjoy Programming :)


Reference Links:
=============================

https://github.com/containers/libpod/issues/4791#issuecomment-575124857